2 Home
Sebastian Kupke edited this page 1 year ago

Stolpersteine beim Update auf PixiJS v5

Der PixiJS Migration Guide von Version 4 auf 5 befindet sich hier.

  • fromImage, fromUrl usw. heißt nur noch from()
  • PIXI.loaders.Loader wurde zu PIXI.Loader.shared
  • beginFill(0xffffff, 0) sollte nicht verwendet werden, lieber beginFill(0xffffff); ...alpha = 0, weitere Infos hier
  • .fillAlpha, .fillColor, ... wird zu .fill.alpha and .fill.color
  • drawPolygon(), addHole() wurde zu beginHole(), drawPolygon(), endHole()
  • Namespaces einiger Settings haben sich verändert, z. B. von PIXI.Graphics.CURVES.adaptive = true zu PIXI.GRAPHICS_CURVES.adaptive = true
  • PIXI.Polygon.close() gibt es nicht mehr, Workaround: if (shape.points[0] !== shape.points[shape.points.length - 2] || shape.points[1] !== shape.points[shape.points.length - 1]) { shape.points.push(shape.points[0], shape.points[1]) }
  • Weitere Infos: v5-Migration-Guide