Update to Pixi.JS 5.0 #4

Closed
opened 3 years ago by skupke · 4 comments
skupke commented 3 years ago
Owner

Working on this in branch pixijs-v5.

Working on this in branch pixijs-v5.
Poster
Owner

Dependencies ready for 5.0?

### Dependencies ready for 5.0? - pixi-filters: Works with PixiJS 5.0 - pixi-particles: Works with PixiJS 5.0 - pixi-projection: Works with PixiJS 5.0 - pixi-ease: Works with PixiJS 5.0 - pixi-viewport: Works with PixiJS 5.0 - pixi-compressed-textures: Currently no support for PixiJS 5.0 (https://github.com/pixijs/pixi.js/projects/6#card-8408373) but planned for 5.1.1 (https://github.com/pixijs/pixi-compressed-textures/issues/22)
skupke added the
Enhancement
label 3 years ago
skupke self-assigned this 3 years ago
Poster
Owner

pixi-compressed-textures v2.0.0 supports PixiJS 5.1.3, but:

  • pixi-compressed-textures runs with Google Chrome
  • pixi-compressed-textures runs with Safari but only with WebGL 1!!

Tests: https://gitea.iwm-tuebingen.de/skupke/PixiJSv5CompressedTextures.git

pixi-compressed-textures v2.0.0 supports PixiJS 5.1.3, but: - pixi-compressed-textures runs with Google Chrome - pixi-compressed-textures runs with Safari but only with WebGL 1!! Tests: https://gitea.iwm-tuebingen.de/skupke/PixiJSv5CompressedTextures.git
Poster
Owner

Use pixi-compressed-textures v1.1.8 for PixiJS 4.x.x

Use pixi-compressed-textures v1.1.8 for PixiJS 4.x.x
Poster
Owner

Implemented.

Implemented.
skupke closed this issue 3 years ago
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.